aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb b/meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb
new file mode 100644
index 0000000000..911cf4ec3f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "passive checker of Python programs"
+HOMEPAGE = "https://github.com/dreamhost/cliff"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=690c2d09203dc9e07c4083fc45ea981f"
+
+SRC_URI[md5sum] = "48b1c29732ca810a70cba0e6d0531169"
+SRC_URI[sha256sum] = "35b2d75ee967ea93b55750aa9edbbf72813e06a66ba54438df2cfac9e3c27fc8"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-prettytable \
+ ${PYTHON_PN}-cmd2 \
+ ${PYTHON_PN}-pyparsing"
+
+BBCLASSEXTEND = "native nativesdk"