aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-iso8601_0.1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-iso8601_0.1.12.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-iso8601_0.1.12.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-iso8601_0.1.12.bb b/meta-python/recipes-devtools/python/python3-iso8601_0.1.12.bb
index 4a332b53bd..74b5bdcb87 100644
--- a/meta-python/recipes-devtools/python/python3-iso8601_0.1.12.bb
+++ b/meta-python/recipes-devtools/python/python3-iso8601_0.1.12.bb
@@ -1,2 +1,16 @@
+SUMMARY = "Simple module to parse ISO 8601 dates"
+HOMEPAGE = "http://pyiso8601.readthedocs.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b05625f2336fa024e8d57e65c6595844"
+
+SRC_URI[md5sum] = "4de940f691c5ea759fb254384c8ddcf6"
+SRC_URI[sha256sum] = "49c4b20e1f38aa5cf109ddcd39647ac419f928512c869dc01d5c7098eddede82"
+
inherit pypi setuptools3
-require python-iso8601.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"