aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-click_7.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-click_7.1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-click_7.1.2.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-click_7.1.2.bb b/meta-python/recipes-devtools/python/python3-click_7.1.2.bb
index fa29d11ab8..0b513e7cb9 100644
--- a/meta-python/recipes-devtools/python/python3-click_7.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-click_7.1.2.bb
@@ -11,7 +11,22 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
SRC_URI[md5sum] = "53692f62cb99a1a10c59248f1776d9c0"
SRC_URI[sha256sum] = "d2b5255c7c6349bc1bd1e59e08cd12acbbd63ce649f2588755783aa94dfb6b1a"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"