aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/mplayer/mplayer2/cross.compile.codec-cfg.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-multimedia/mplayer/mplayer2/cross.compile.codec-cfg.patch')
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mplayer2/cross.compile.codec-cfg.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mplayer2/cross.compile.codec-cfg.patch b/meta-oe/recipes-multimedia/mplayer/mplayer2/cross.compile.codec-cfg.patch
new file mode 100644
index 0000000000..7b290b5051
--- /dev/null
+++ b/meta-oe/recipes-multimedia/mplayer/mplayer2/cross.compile.codec-cfg.patch
@@ -0,0 +1,16 @@
+Upstream-Status: Pending
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
+diff --git a/Makefile b/Makefile
+index 6013ca3..28c6383 100644
+--- a/Makefile
++++ b/Makefile
+@@ -600,7 +602,7 @@ mplayer$(EXESUF):
+ $(CC) -o $@ $^ $(EXTRALIBS)
+
+ codec-cfg$(EXESUF): codec-cfg.c codec-cfg.h
+- $(HOST_CC) -O -DCODECS2HTML -I. -o $@ $<
++ $(BUILD_CC) -O -DCODECS2HTML -I. -Iffmpeg -o $@ $<
+
+ codecs.conf.h: codec-cfg$(EXESUF) etc/codecs.conf
+ ./$^ > $@