aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-graphics/ydotool/ydotool_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/ydotool/ydotool_git.bb b/meta-oe/recipes-graphics/ydotool/ydotool_git.bb
index c1427457d1..3acf70235e 100644
--- a/meta-oe/recipes-graphics/ydotool/ydotool_git.bb
+++ b/meta-oe/recipes-graphics/ydotool/ydotool_git.bb
@@ -16,5 +16,11 @@ EXTRA_OECMAKE = "\
-DBUILD_DOCS=OFF \
"
+do_install:append() {
+ if ! ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ rm -rf ${D}${systemd_user_unitdir}
+ rmdir ${D}${nonarch_libdir}/systemd ${D}${nonarch_libdir}
+ fi
+}
SYSTEMD_SERVICE:${PN} = "ydotoold.service"
SYSTEMD_AUTO_ENABLE = "disable"