aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-11-12 21:05:47 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-16 08:25:15 -0800
commiteac7414c368313a453661803a6b1ecb1e986efd1 (patch)
tree9879dec361b60cec9fe958262f2d76c6972600ba /meta-python
parentbcb17fa46a7be97992f6bd2cb8e716074dfeecc8 (diff)
downloadmeta-openembedded-eac7414c368313a453661803a6b1ecb1e986efd1.tar.gz
python3-coverage: Upgrade 6.1.1 -> 6.1.2
Upgrade to release 6.1.2: - Python 3.11 is supported (tested with 3.11.0a2). One still-open issue has to do with exits through with-statements. - Fix: When remapping file paths through the [paths] setting while combining, the [run] relative_files setting was ignored, resulting in absolute paths for remapped file names. This is now fixed. - Fix: Complex conditionals over excluded lines could have incorrectly reported a missing branch. This is now fixed. - Fix: More exceptions are now handled when trying to parse source files for reporting. Problems that used to terminate coverage.py can now be handled with [report] ignore_errors. This helps with plugins failing to read files. - Fix: Removed another vestige of jQuery from the source tarball. - Fix: Added a default value for a new-to-6.x argument of an internal class. This unsupported class is being used by coveralls. Although I'd rather not "fix" unsupported interfaces, it's actually nicer with a default value. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-coverage_6.1.2.bb (renamed from meta-python/recipes-devtools/python/python3-coverage_6.1.1.bb)5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-coverage_6.1.1.bb b/meta-python/recipes-devtools/python/python3-coverage_6.1.2.bb
index a99fca2cb8..c456800c53 100644
--- a/meta-python/recipes-devtools/python/python3-coverage_6.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-coverage_6.1.2.bb
@@ -3,7 +3,10 @@ HOMEPAGE = "https://coverage.readthedocs.io"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
-SRC_URI[sha256sum] = "b8e4f15b672c9156c1154249a9c5746e86ac9ae9edc3799ee3afebc323d9d9e0"
+SRC_URI[sha256sum] = "d9a635114b88c0ab462e0355472d00a180a5fbfd8511e7f18e4ac32652e7d972"
inherit pypi setuptools3
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-sqlite3 \
+"