aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-11-16 11:35:55 +0800
committerKhem Raj <raj.khem@gmail.com>2021-11-17 09:24:26 -0800
commitadc3781e368c6b89cf212df8180169e37e2d50a9 (patch)
treed82b0b29fdd6cf296395fe3ad4032ccdcc644d61 /meta-python
parent2995484dc2355394c0b8a908f2003934cf3c8598 (diff)
downloadmeta-openembedded-adc3781e368c6b89cf212df8180169e37e2d50a9.tar.gz
python3-cmd2: upgrade 2.2.0 -> 2.3.0
Bug Fixes Fixed AttributeError in rl_get_prompt() when prompt is None. Fixed bug where using choices on a Settable didn't verify that a valid choice had been entered. Fixed bug introduced in cmd2 2.0.0 in which select() converts return values to strings. It should never have converted return values. Enhancements Added settings to Column class which prevent a table from overriding existing styles in header and/or data text. This allows for things like nesting an AlternatingTable in another AlternatingTable. AlternatingTable no longer automatically applies background color to borders. This was done to improve appearance since the background color extended beyond the borders of the table. Added ability to colorize all aspects of AlternatingTables, BorderedTables, and SimpleTables. Added support for 8-bit/256-colors with the cmd2.EightBitFg and cmd2.EightBitBg classes. Added support for 24-bit/RGB colors with the cmd2.RgbFg and cmd2.RgbBg classes. Removed dependency on colorama. Changed type of ansi.allow_style from a string to an ansi.AllowStyle Enum class. Deprecations Deprecated cmd2.fg. Use cmd2.Fg instead. Deprecated cmd2.bg. Use cmd2.Bg instead. Breaking Changes To support the color upgrade, all cmd2 colors now inherit from either ansi.FgColor or ansi.BgColor. Therefore, ansi.style() no longer accepts colors as strings. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cmd2_2.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb b/meta-python/recipes-devtools/python/python3-cmd2_2.3.0.bb
index 2632ce1c80..0cc8e9ce50 100644
--- a/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cmd2_2.3.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4c527bcb481233ebcb803de975f42701"
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
-SRC_URI[sha256sum] = "34cd12424d9e2835eff125146af3d9f4a4c2931c6bc5a3cea9790bd4f55756d9"
+SRC_URI[sha256sum] = "2493ab8e5baab3d1a0325ea50920674a63de41bee4c63a634ac5cb42bfd63c1b"
inherit pypi setuptools3