aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-11-15 20:56:52 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-16 08:25:15 -0800
commit2f27988b8359b38bb44286731c06b1ea2b018964 (patch)
tree486afd7fa6407febe657f90385b13c8cfa08263c /meta-python
parentf40cec6b67c9b59c528371726898d0eb5289b2a4 (diff)
downloadmeta-openembedded-2f27988b8359b38bb44286731c06b1ea2b018964.tar.gz
python3-aiohttp: Upgrade 3.8.0 -> 3.8.1
Upgrade to release 3.8.1: - Fix the error in handling the return value of getaddrinfo. getaddrinfo will return an (int, bytes) tuple, if CPython could not handle the address family. It will cause a index out of range error in aiohttp. For example, if user compile CPython with --disable-ipv6 option but his system enable the ipv6. - Do not install "examples" as a top-level package. - Restored ability to connect IPv6-only host. - Remove Signal from __all__, replace aiohttp.Signal with aiosignal.Signal in docs - Made chunked encoding HTTP header check stricter Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb (renamed from meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb)5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb
index 710f8f4ceb..1d8434e3ca 100644
--- a/meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/aio-libs/aiohttp"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8074d6c6e217873b2a018a4522243ea3"
-SRC_URI[sha256sum] = "d3b19d8d183bcfd68b25beebab8dc3308282fe2ca3d6ea3cb4cd101b3c279f8d"
+SRC_URI[sha256sum] = "fc5471e1a54de15ef71c1bc6ebe80d4dc681ea600e68bfd1cbce40427f0b7578"
PYPI_PACKAGE = "aiohttp"
inherit setuptools3 pypi
@@ -20,4 +20,7 @@ RDEPENDS:${PN} = "\
${PYTHON_PN}-netserver \
${PYTHON_PN}-typing-extensions \
${PYTHON_PN}-yarl \
+ ${PYTHON_PN}-cchardet \
+ ${PYTHON_PN}-charset-normalizer \
+ ${PYTHON_PN}-aiosignal \
"