aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorGeoff Parker <geoffrey.parker@arthrex.com>2021-11-21 17:18:19 -0800
committerKhem Raj <raj.khem@gmail.com>2021-11-21 22:06:22 -0800
commit00083a8dc5a608502f6192452c7cd54b86c956d0 (patch)
treead55933b40f5415016932e67cf986086039a00f7 /meta-python
parentee97801c1e1728309307d0cbe5ff69317e23af2b (diff)
downloadmeta-openembedded-00083a8dc5a608502f6192452c7cd54b86c956d0.tar.gz
python3-aiosignal, python3-frozenlist: Add native & nativestdk package support
Add 'BBCLASSEXTEND = "native nativesdk"' to python3-aiosignal and it's RDEPENDS python3-frozenlist. Signed-off-by: Geoff Parker <geoffrey.parker@arthrex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb3
2 files changed, 5 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb b/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb
index 601ac8f458..efd94f7934 100644
--- a/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb
@@ -7,6 +7,8 @@ SRC_URI[sha256sum] = "78ed67db6c7b7ced4f98e495e572106d5c432a93e1ddd1bf475e1dc05f
inherit pypi setuptools3
+BBCLASSEXTEND = "native nativesdk"
+
RDEPENDS:${PN} = "\
${PYTHON_PN}-frozenlist \
"
diff --git a/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb b/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb
index b56e2e5e66..e8359418b0 100644
--- a/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb
@@ -6,3 +6,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=cf056e8e7a0a5477451af18b7b5aa98c"
SRC_URI[sha256sum] = "68201be60ac56aff972dc18085800b6ee07973c49103a8aba669dee3d71079de"
inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"
+