aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-05-12 19:34:18 -0400
committerKhem Raj <raj.khem@gmail.com>2020-05-12 16:53:46 -0700
commitf92b959f4a52ec7596aace92c8d37a370a132f30 (patch)
tree667badaae4ceef99d7abe3fa78b2f280de35413a /meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
parent5fceaa4964fdbc2a76aec6d774843914c57221ee (diff)
downloadmeta-openembedded-f92b959f4a52ec7596aace92c8d37a370a132f30.tar.gz
python3-werkzeug: add python3-logging to RDEPENDS
werkzeug relies on the logging module, but it is not in RDEPENDS, so add it: |Python 3.8.2 (default, Apr 27 2020, 08:51:00) |[GCC 9.3.0] on linux |Type "help", "copyright", "credits" or "license" for more information. |>>> import werkzeug |Traceback (most recent call last): |File "<stdin>", line 1, in <module> |File "/usr/lib64/python3.8/site-packages/werkzeug/_init_.py", line 15, in <module> |from .serving import run_simple |File "/usr/lib64/python3.8/site-packages/werkzeug/serving.py", line 50, in <module> |from ._internal import _log |File "/usr/lib64/python3.8/site-packages/werkzeug/_internal.py", line 12, in <module> |import logging |ModuleNotFoundError: No module named 'logging' Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
index b54399e1c8..58735c1c02 100644
--- a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
@@ -26,6 +26,7 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-html \
${PYTHON_PN}-io \
${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
${PYTHON_PN}-netclient \
${PYTHON_PN}-netserver \
${PYTHON_PN}-numbers \