aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-03 19:03:08 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-03 16:43:10 -0700
commitb79c99dbd4962de60eff5d706a932515951e66eb (patch)
treef4ace83abb774d4a78d2eeea0fba86c929090438 /meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb
parent240578f2c8ec7af8b8968b4e0122c981cd990a82 (diff)
downloadmeta-openembedded-b79c99dbd4962de60eff5d706a932515951e66eb.tar.gz
python-werkzeug: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb50
1 files changed, 48 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb
index 145a1de0a1..3e4374ed4b 100644
--- a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb
@@ -1,4 +1,50 @@
+SUMMARY = "The Swiss Army knife of Python web development"
+DESCRIPTION = "\
+Werkzeug started as simple collection of various utilities for WSGI \
+applications and has become one of the most advanced WSGI utility modules. \
+It includes a powerful debugger, full featured request and response objects, \
+HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
+cookie handling, file uploads, a powerful URL routing system and a bunch \
+of community contributed addon modules."
+HOMEPAGE = "http://werkzeug.pocoo.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
+
+SRC_URI[md5sum] = "305f75c4a88c96dcdc5654bf2d01bc05"
+SRC_URI[sha256sum] = "169ba8a33788476292d04186ab33b01d6add475033dfc07215e6d219cc077096"
+
+PYPI_PACKAGE = "Werkzeug"
+
inherit pypi setuptools3
-require python-werkzeug.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-misc"
+CLEANBROKEN = "1"
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests+= " \
+ ${PYTHON_SITEPACKAGES_DIR}/werkzeug/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/werkzeug/__pycache__/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/werkzeug/contrib/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/werkzeug/contrib/__pycache__/test* \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
+"
+
+RDEPENDS_${PN}-tests = " \
+ ${PN} \
+ ${PYTHON_PN}-unittest \
+"