aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-29 15:12:33 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-30 07:50:52 -0700
commit2927427fb53eb4a9b99af1400ca9b8f781c23330 (patch)
tree18cf95b5310eb56aa6b2128383e4b2e17a7c1c60 /meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
parenta1e9e980032f5937b516561509515ccb47f35eeb (diff)
downloadmeta-openembedded-2927427fb53eb4a9b99af1400ca9b8f781c23330.tar.gz
python3-watchdog: Upgrade 0.10.2 -> 0.10.3
Upgrade to release 0.10.3: - Ensure ObservedWatch.path is a string - [inotify] Allow to monitor single file - [inotify] Prevent raising an exception when a file in a monitored folder has no permissions Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb b/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
new file mode 100644
index 0000000000..2108cbb93b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Filesystem events monitoring"
+DEPENDS = "${PYTHON_PN}-argh"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "9a5c9134e943b534b9f8b51d78338cf8"
+SRC_URI[sha256sum] = "4214e1379d128b0588021880ccaf40317ee156d4603ac388b9adcf29165e0c04"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-argh \
+ ${PYTHON_PN}-pathtools3 \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-requests \
+"
+
+BBCLASSEXTEND = "native nativesdk"