aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-21 14:16:09 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-22 22:17:30 -0700
commit1a53121ff54732648a4ee1e96643106d4d36c524 (patch)
tree588e71bd20b2f8bad10e9fad9c7049d7967ed2ae /meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb
parentaa4f5c9f968cba62ae95132b2000d57e12809bcc (diff)
downloadmeta-openembedded-1a53121ff54732648a4ee1e96643106d4d36c524.tar.gz
python3-typeguard: Upgrade 2.9.1 -> 2.10.0
Upgrade to release 2.10.0: - Added support for Python 3.9 - Added support for nested Literal - Added support for TypedDict inheritance (with some caveats; see the user guide on that for details) - An appropriate TypeError is now raised when encountering an illegal Literal value - Fixed checking NoReturn on Python < 3.8 when typing_extensions was not installed - Fixed import hook matching unwanted modules - Install the pytest plugin earlier in the test run to support more use cases Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb b/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb
new file mode 100644
index 0000000000..bd92216776
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Run-time type checker for Python"
+HOMEPAGE = "https://pypi.org/project/typeguard/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
+
+SRC_URI[md5sum] = "cc43e0eb1dea7e409a74c7f1effc4544"
+SRC_URI[sha256sum] = "d830132dcd544d3f8a2a842ea739eaa0d7c099fcebb9dcdf3802f4c9929d8191"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-typing-extensions \
+ ${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+DEPENDS += "\
+ python3-distutils-extra-native \
+ python3-setuptools-scm-native \
+"
+
+RDEPENDS_${PN} += "python3-typing"
+
+BBCLASSEXTEND = "native nativesdk"