aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyperf_1.7.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 12:41:57 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commitf4f4b23d46518e3215fd12410b295cf8143f7191 (patch)
tree83297b559998aa773602a59baa304c9405960593 /meta-python/recipes-devtools/python/python3-pyperf_1.7.1.bb
parent394857d81e78556ebf65b67c556a731dbc5b9645 (diff)
downloadmeta-openembedded-f4f4b23d46518e3215fd12410b295cf8143f7191.tar.gz
python-pyperf: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyperf_1.7.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperf_1.7.1.bb24
1 files changed, 22 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyperf_1.7.1.bb b/meta-python/recipes-devtools/python/python3-pyperf_1.7.1.bb
index 5ba5efb05d..081e904e16 100644
--- a/meta-python/recipes-devtools/python/python3-pyperf_1.7.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyperf_1.7.1.bb
@@ -1,4 +1,24 @@
-inherit setuptools3
-require python-pyperf.inc
+SUMMARY = "A toolkit to write, run and analyze benchmarks"
+DESCRIPTION = " \
+The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
+Features: \
+ * Simple API to run reliable benchmarks \
+ * Automatically calibrate a benchmark for a time budget. \
+ * Spawn multiple worker processes. \
+ * Compute the mean and standard deviation. \
+ * Detect if a benchmark result seems unstable. \
+ * JSON format to store benchmark results. \
+ * Support multiple units: seconds, bytes and integer. \
+"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
+
+SRC_URI[md5sum] = "d9e894dc843bb7f0abff109931a29895"
+SRC_URI[sha256sum] = "c37690e810116a83a244dfeec47885e2f0475b4c450313904be3bc2cdaf6d50a"
+
+DEPENDS += "${PYTHON_PN}-six-native"
+
+PYPI_PACKAGE = "pyperf"
+inherit pypi setuptools3
RDEPENDS_${PN} += "${PYTHON_PN}-misc"