aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-29 20:18:48 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-03 18:06:32 -0700
commit572301b93497c3165db27246f6f1394109868527 (patch)
treee8911897aa23c42eea75840d1cac7a4b62eac732 /meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb
parentbcbe9a4bcc4974cceefd485d426738cab78ce70b (diff)
downloadmeta-openembedded-572301b93497c3165db27246f6f1394109868527.tar.gz
python3-pyflakes: Upgrade 2.1.1 -> 2.2.0
Use LICENSE instead of README.rst for LIC_FILES_CHKSUM. Upgrade to release 2.2.0: - Include column information in error messages - Fix @overload detection with other decorators and in non-global scopes - Fix return-type annotation being a class member - Fix assignment to _ in doctests with existing _ name - Namespace attributes which are attached to ast nodes with _pyflakes_ to avoid conflicts with other libraries (notably bandit) - Add check for f-strings without placeholders - Add check for unused/extra/invalid 'string literal'.format(...) - Add check for unused/extra/invalid 'string literal % ... - Improve python shebang detection - Allow type ignore to be followed by a code # type: ignore[attr-defined] - Add support for assignment expressions (PEP 572) - Support @overload detection from typing_extensions as well - Fix @overload detection for async functions - Allow continue inside finally in python 3.8+ - Fix handling of annotations in positional-only arguments - Make pyflakes more resistant to future syntax additions - Fix false positives in partially quoted type annotations - Warn about is comparison to tuples - Fix Checker usage with async function subtrees - Add check for if of non-empty tuple - Switch from optparse to argparse - Fix false positives in partially quoted type annotations in unusual contexts - Be more cautious when identifying Literal type expressions Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb b/meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb
new file mode 100644
index 0000000000..911cf4ec3f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyflakes_2.2.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "passive checker of Python programs"
+HOMEPAGE = "https://github.com/dreamhost/cliff"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=690c2d09203dc9e07c4083fc45ea981f"
+
+SRC_URI[md5sum] = "48b1c29732ca810a70cba0e6d0531169"
+SRC_URI[sha256sum] = "35b2d75ee967ea93b55750aa9edbbf72813e06a66ba54438df2cfac9e3c27fc8"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-prettytable \
+ ${PYTHON_PN}-cmd2 \
+ ${PYTHON_PN}-pyparsing"
+
+BBCLASSEXTEND = "native nativesdk"