aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-26 11:02:13 +0200
committerKhem Raj <raj.khem@gmail.com>2020-10-28 10:22:05 -0700
commite37647c283d9ef868ae92fa115c0e438704bba35 (patch)
treef0bb42627a25759e495e5053a1cc7a07fc6e0aaa /meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb
parenta00b9d8eba6e9b0057a64f1d0334e9e287997845 (diff)
downloadmeta-openembedded-e37647c283d9ef868ae92fa115c0e438704bba35.tar.gz
python3-psutil: Upgrade 5.7.2 -> 5.7.3
Upgrade to release 5.7.3: - [FreeBSD] add support for Process.rlimit(). - [BSD] add support for Process.environ() - [UNIX] net_if_stats()'s isup also checks whether the NIC is running (meaning Wi-Fi or ethernet cable is connected) - [Linux] improved battery detection and charge "secsleft" calculation - [Linux] physical cpu_count() result is incorrect on systems with more than one CPU socket - [macOS] Process.exe() may raise FileNotFoundError if process is still alive but the exe file which launched it got deleted - [macOS] fix missing include for getpagesize() - [Windows] Process.open_files() may cause a segfault due to a NULL pointer - [Linux] sensors_battery(): if percent can be determined but not the remaining values, still return a result instead of None. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb b/meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb
new file mode 100644
index 0000000000..2f927d2da2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb
@@ -0,0 +1,25 @@
+SUMMARY = "A cross-platform process and system utilities module for Python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
+
+SRC_URI[md5sum] = "b07a067e6a930608235f4e5d9b1f90f5"
+SRC_URI[sha256sum] = "af73f7bcebdc538eda9cc81d19db1db7bf26f103f91081d780bbacfcb620dee2"
+
+inherit pypi setuptools3
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
+"
+
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-netclient \
+"
+
+BBCLASSEXTEND = "native nativesdk"