aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-12-30 12:56:48 +0800
committerArmin Kuster <akuster808@gmail.com>2023-02-11 10:50:32 -0500
commit6e01fb8272a93db3cbcc6fd66abe41ac25564578 (patch)
tree938c91ae968a915e693cf6c581ef0f3a211300fc /meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
parentc1dcb34a717022d247685b2ec66492c41febe902 (diff)
downloadmeta-openembedded-6e01fb8272a93db3cbcc6fd66abe41ac25564578.tar.gz
python3-pillow: upgrade 9.3.0 -> 9.4.0
License-Updated: copyright year updated to 2023 Changelog: ========== Fixed null pointer dereference crash with malformed font #6846 Return from ImagingFill early if image has a zero dimension #6842 Reversed deprecations for Image constants, except for duplicate Resampling attributes #6830 Improve exception traceback readability #6836 Do not attempt to read IFD1 if absent #6840 Fixed writing int as ASCII tag #6800 If available, use wl-paste or xclip for grabclipboard() on Linux #6783 Added signed option when saving JPEG2000 images #6709 Patch OpenJPEG to include ARM64 fix #6718 Added support for I;16 modes in putdata() #6825 Added conversion from RGBa to RGB #6708 Added DDS support for uncompressed L and LA images #6820 Added LightSource tag values to ExifTags #6749 Fixed PyAccess after changing ICO size #6821 Do not use EXIF from info when saving PNG images #6819 Fixed saving EXIF data to MPO #6817 Added Exif hide_offsets() #6762 Only compare to previous frame when checking for duplicate GIF frames while saving #6787 Always initialize all plugins in registered_extensions() #6811 Ignore non-opaque WebP background when saving as GIF #6792 Only set tile in ImageFile __setstate__ #6793 When reading BLP, do not trust JPEG decoder to determine image is CMYK #6767 Added IFD enum to ExifTags #6748 Fixed bug combining GIF frame durations #6779 Support saving JPEG comments #6774 Added getxmp() to WebPImagePlugin #6758 Added "exact" option when saving WebP #6747 Use fractional coordinates when drawing text #6722 Fixed writing int as BYTE tag #6740 Added MP Format Version when saving MPO #6735 Added Interop to ExifTags #6724 CVE-2007-4559 patch when building on Windows #6704 Fix compiler warning: accessing 64 bytes in a region of size 48 #6714 Use verbose flag for pip install #6713 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit b73867b9d77e8050c20dc28ec449572f2185cb2a) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb b/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
new file mode 100644
index 0000000000..403a987d1e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
@@ -0,0 +1,42 @@
+SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
+Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
+Contributors."
+HOMEPAGE = "https://pillow.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bc416d18f294943285560364be7cbec1"
+
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
+ file://0001-support-cross-compiling.patch \
+ file://0001-explicitly-set-compile-options.patch \
+ "
+SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
+
+inherit setuptools3
+
+PIP_INSTALL_PACKAGE = "Pillow"
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+
+DEPENDS += " \
+ zlib \
+ jpeg \
+ tiff \
+ freetype \
+ lcms \
+ openjpeg \
+"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+"
+
+CVE_PRODUCT = "pillow"
+
+S = "${WORKDIR}/git"
+
+RPROVIDES:${PN} += "python3-imaging"
+
+BBCLASSEXTEND = "native"
+
+SRCREV = "a5bbab1c1e63b439de191ef2040173713b26d2da"