aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-msm_0.8.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-24 17:50:04 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:34:33 -0700
commitfc1a921c89b3ec6366c8de958e30a9995ad9281b (patch)
treed5336ed8331d3205f2864cca98bcccdff9d00dfc /meta-python/recipes-devtools/python/python3-msm_0.8.8.bb
parent28619bb56c9aeb3d71d15bd2924205a7936702a6 (diff)
downloadmeta-openembedded-fc1a921c89b3ec6366c8de958e30a9995ad9281b.tar.gz
python3-msm: Upgrade 0.8.7 -> 0.8.8
Upgrade to release 0.8.8: - increment mycroft-skills repo branch - Make sure readme is included in pip package - Add license to MANIFEST.in - Remove exec flag from LICENSE - Handle PermissionsError when creating skills repo - Concatenate list and not a string - Install Python packages in the exact order as specified in the manifest file Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-msm_0.8.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-msm_0.8.8.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-msm_0.8.8.bb b/meta-python/recipes-devtools/python/python3-msm_0.8.8.bb
new file mode 100644
index 0000000000..f5e3f59cd5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-msm_0.8.8.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Mycroft Skill Manager, in python!"
+HOMEPAGE = "https://github.com/MycroftAI/mycroft-skills-manager"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
+
+SRC_URI[md5sum] = "cf1fc0d1d86af68003cae53c71ec6288"
+SRC_URI[sha256sum] = "a502aee54917cd394217b31c977a1ba3d9541a0120e0a045c49fd77b328e4a29"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ python3-pako \
+ python3-monotonic \
+ python3-appdirs \
+"
+
+do_install_append() {
+ # Stop this from being installed
+ rm -rf ${D}/usr/share
+}