aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask_1.1.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-25 16:26:33 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-27 15:07:35 -0700
commit2e13bf296ada1937eaf2125dc4565ea9b8bd746e (patch)
tree4208461546b443a924c9ac9af1d3525eadc06165 /meta-python/recipes-devtools/python/python3-flask_1.1.2.bb
parente5a2438e3e94410130a820cad3de65bc53bd0d56 (diff)
downloadmeta-openembedded-2e13bf296ada1937eaf2125dc4565ea9b8bd746e.tar.gz
python3-flask: Upgrade 1.1.1 -> 1.1.2
Upgrade to release 1.1.2: - Work around an issue when running the flask command with an external debugger on Windows. - The static route will not catch all URLs if the Flask static_folder argument ends with a slash. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask_1.1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_1.1.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask_1.1.2.bb b/meta-python/recipes-devtools/python/python3-flask_1.1.2.bb
new file mode 100644
index 0000000000..23799617fe
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask_1.1.2.bb
@@ -0,0 +1,18 @@
+SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
+DESCRIPTION = "\
+Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
+intentions. And before you ask: It’s BSD licensed!"
+HOMEPAGE = "https://github.com/mitsuhiko/flask/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
+
+SRC_URI[md5sum] = "0da4145d172993cd28a6c619630cc19c"
+SRC_URI[sha256sum] = "4efa1ae2d7c9865af48986de8aeb8504bf32c7f3d6fdc9353d34b21f4b127060"
+
+PYPI_PACKAGE = "Flask"
+
+inherit pypi setuptools3
+
+CLEANBROKEN = "1"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-werkzeug ${PYTHON_PN}-jinja2 ${PYTHON_PN}-itsdangerous ${PYTHON_PN}-click"