aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-02-22 14:11:57 +0200
committerKhem Raj <raj.khem@gmail.com>2022-02-24 08:30:26 -0800
commitaa294ca1aa5fe921902446cecf690a163131a285 (patch)
tree33dd359cdcaf92f169b1057f3e2aa5b98da0941c /meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
parent87ae20aa982a10ca1a68daf573dbe65db9a12231 (diff)
downloadmeta-openembedded-aa294ca1aa5fe921902446cecf690a163131a285.tar.gz
python3-distro: Upgrade 1.6.0 -> 1.7.0
Upgrade to release 1.7.0: - Dropped support for EOL Pythons 2.7, 3.4 and 3.5 - Dropped support for LSB and uname back-ends when --root-dir is specified - Moved distro.py to src/distro/distro.py - Documented that distro.version() can return an empty string on rolling releases - Documented support for Python 3.10 - Added official support for Rocky Linux distribution - Added a shebang to distro.py to allow standalone execution - Added support for AIX platforms - Added compliance for PEP-561 - Fixed include_uname parameter oversight - Fixed crash when uname -rs output is empty - Fixed Amazon Linux identifier in distro.id() documentation - Fixed OpenSuse >= 15 support - Fixed encoding issues when opening distro release files - Fixed linux_distribution regression Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-distro_1.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-distro_1.7.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb b/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
new file mode 100644
index 0000000000..f069234d1b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Distro is an OS platform information API"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+PYPI_PACKAGE = "distro"
+
+SRC_URI[sha256sum] = "151aeccf60c216402932b52e40ee477a939f8d58898927378a02abbe852c1c39"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"