aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-30 20:11:15 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-03 18:07:28 -0700
commit4b01bced9c29d69d2981fc19b82594a83219fdf5 (patch)
tree16747b48e4d27176f233c277f0fa6aae33d93639 /meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb
parentd33aa89269f85461523b288811f94e6503fbf313 (diff)
downloadmeta-openembedded-4b01bced9c29d69d2981fc19b82594a83219fdf5.tar.gz
python3-cachetools: Upgrade 4.1.0 -> 4.1.1
Upgrde to release 4.1.1: - Improve popitem() exception context handling. - Replace float('inf') with math.inf. - Improve "envkey" documentation example. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb b/meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb
new file mode 100644
index 0000000000..d334070cdb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachetools_4.1.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Extensible memoizing collections and decorators"
+HOMEPAGE = "https://github.com/tkem/cachetools"
+DESCRIPTION = "This module provides various memoizing \
+collections and decorators, including variants of the \
+Python 3 Standard Library @lru_cache function decorator."
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+SRC_URI[md5sum] = "ae41b69896f49727e1621d279cb72522"
+SRC_URI[sha256sum] = "bbaa39c3dede00175df2dc2b03d0cf18dd2d32a7de7beb68072d13043c9edb20"
+
+BBCLASSEXTEND = "native nativesdk"