aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 13:45:18 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit6b2ad450c16e94a562b44ae08b117f078a47235e (patch)
tree580f06bfef9573dc8961aa93db8b28b1336adbbf /meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb
parent4990f80ddbc984f2bed4e07005d22f937988827e (diff)
downloadmeta-openembedded-6b2ad450c16e94a562b44ae08b117f078a47235e.tar.gz
python3-bcrypt: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb b/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb
index d2ec9e386c..0f2d31f537 100644
--- a/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb
+++ b/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb
@@ -1,2 +1,17 @@
-inherit setuptools3
-require python-bcrypt.inc
+DESCRIPTION = "Modern password hashing for your software and your servers."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
+
+DEPENDS += "${PYTHON_PN}-cffi-native"
+
+SRC_URI[md5sum] = "5d6f93b575ce52470af37a8e7dce76fe"
+SRC_URI[sha256sum] = "0b0069c752ec14172c5f78208f1863d7ad6755a6fae6fe76ec2c80d13be41e42"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-six \
+"