aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/fbtest/fb-test_1.1.0.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2021-12-05 21:05:31 +0100
committerKhem Raj <raj.khem@gmail.com>2021-12-06 09:56:50 -0800
commitc57e4d5faa3d1c4b23173a4f26b2cd1aff846b34 (patch)
tree2989aa6da1f8a1c5a2f91052b2dab66fe6026e4d /meta-oe/recipes-test/fbtest/fb-test_1.1.0.bb
parentf0b4e37b77efe727cf2b3288256609eae8ceb119 (diff)
downloadmeta-openembedded-c57e4d5faa3d1c4b23173a4f26b2cd1aff846b34.tar.gz
fb-test: fix SRC_URI
Original repo doesn't exist any more. Even though I couldn't find any new official repo, this is the only one on github that contains used commit hash. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/fbtest/fb-test_1.1.0.bb')
-rw-r--r--meta-oe/recipes-test/fbtest/fb-test_1.1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/fbtest/fb-test_1.1.0.bb b/meta-oe/recipes-test/fbtest/fb-test_1.1.0.bb
new file mode 100644
index 0000000000..14ab41b144
--- /dev/null
+++ b/meta-oe/recipes-test/fbtest/fb-test_1.1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Test suite for Linux framebuffer"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SRCREV = "063ec650960c2d79ac51f5c5f026cb05343a33e2"
+SRC_URI = "git://github.com//ponty/fb-test-app.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fb-test ${D}${bindir}
+ # avoid collisions with perf (perf) and mesa-demos (offset)
+ for prog in perf rect offset ; do
+ install -m 0755 $prog ${D}${bindir}/fb-$prog
+ done
+}