aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/nss
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2020-08-28 21:01:34 +0200
committerKhem Raj <raj.khem@gmail.com>2020-08-28 17:16:57 -0700
commit00bd5ad72f3fef26127b1579d9870cd681725893 (patch)
treeb3aeb185873ca85f813b199a1177039a03ef4983 /meta-oe/recipes-support/nss
parent3bc89dc7b3acf0c6c349d929f0e69e889b1eb1c8 (diff)
downloadmeta-openembedded-00bd5ad72f3fef26127b1579d9870cd681725893.tar.gz
nss: fix postinst in do_rootfs for target
Partially revert "nss: fix postinst script for nativesdk build" This reverts commit 31552510b15c1c97aa6cbe180c2bb53d139efbcc. When running in do_rootfs we need to run shlibsign provided by nss-native, otherwise it fails when /usr/bin/shlibsign doesn't exist on host builder: do_rootfs: Postinstall scriptlets of ['nss'] have failed. If the intention is to defer them to first boot, then please place them into pkg_postinst_ontarget_${PN} (). Deferring to first boot via 'exit 1' is no longer supported. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/nss')
-rw-r--r--meta-oe/recipes-support/nss/nss_3.56.bb27
1 files changed, 14 insertions, 13 deletions
diff --git a/meta-oe/recipes-support/nss/nss_3.56.bb b/meta-oe/recipes-support/nss/nss_3.56.bb
index 4aa5d29ec2..107b0a0152 100644
--- a/meta-oe/recipes-support/nss/nss_3.56.bb
+++ b/meta-oe/recipes-support/nss/nss_3.56.bb
@@ -238,20 +238,21 @@ do_install_append_class-target() {
}
PACKAGE_WRITE_DEPS += "nss-native"
+
pkg_postinst_${PN} () {
- if [ -n "$D" ]; then
- for I in $D${libdir}/lib*.chk; do
- DN=`dirname $I`
- BN=`basename $I .chk`
- FN=$DN/$BN.so
- ${bindir}/shlibsign -i $FN
- if [ $? -ne 0 ]; then
- exit 1
- fi
- done
- else
- ${bindir}/signlibs.sh
- fi
+ for I in $D${libdir}/lib*.chk; do
+ DN=`dirname $I`
+ BN=`basename $I .chk`
+ FN=$DN/$BN.so
+ shlibsign -i $FN
+ if [ $? -ne 0 ]; then
+ echo "shlibsign -i $FN failed"
+ fi
+ done
+}
+
+pkg_postinst_ontarget_${PN} () {
+ ${bindir}/signlibs.sh
}
PACKAGES =+ "${PN}-smime"