aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libsoc
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2019-12-11 13:46:58 +0100
committerKhem Raj <raj.khem@gmail.com>2019-12-13 18:29:14 -0800
commita04e0ed79fc9ad048301cafc5c3a79502e466e5c (patch)
tree9d0c29082fa8532beb1b8231a24163c12b9b969d /meta-oe/recipes-support/libsoc
parentba5fbb239e66b9d201bfffa3436d20003b17786f (diff)
downloadmeta-openembedded-a04e0ed79fc9ad048301cafc5c3a79502e466e5c.tar.gz
libsoc: use python3 for python bindings
With python in PACKAGECONFIGS and with the removal of python2 from host tools the recipe fails to build. Change the recipe to use python3. libsoc configure uses the host python to detect the used version, install and use the python3-native package to have the same version for host and target. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libsoc')
-rw-r--r--meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb b/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
index 01708df35a..8b773aefa5 100644
--- a/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
+++ b/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "https://github.com/jackmitch/libsoc"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5"
-inherit autotools pkgconfig python-dir
+inherit autotools pkgconfig python3-dir
SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb"
SRC_URI = "git://github.com/jackmitch/libsoc.git"
@@ -21,7 +21,7 @@ PACKAGECONFIG ?= ""
PACKAGECONFIG[disabledebug] = "--disable-debug,,"
PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
-PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}"
+PACKAGECONFIG[python] = "--enable-python=${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN},,${PYTHON_PN} ${PYTHON_PN}-native"
PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
'${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"