aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-29 21:26:22 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit233d3b20c5892f34ce4949fcf9bb5d9bcde11d56 (patch)
tree6ada12679eb29e1f0cbb336a07b0f27ab9f062be /meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
parent502ec72e60ecdd1bbcaeedefc228cdb9753f0f79 (diff)
downloadmeta-openembedded-233d3b20c5892f34ce4949fcf9bb5d9bcde11d56.tar.gz
fontforge: Upgrade to 20190801 release
License-Update: Dropped plugins [1] and gnulib [2] - Add a fix for musl build to include sys/select.h - gnulib dependency is not needed anymore - Disable libuninameslist, recipe is missing in OE [1] https://github.com/fontforge/fontforge/commit/ed62345e3ad7484cd0bf714f5ef9c7012dad157c#diff-9879d6db96fd29134fc802214163b95a [2] https://github.com/fontforge/fontforge/commit/51c045a09804c20725527878c753df6ba96dafa8#diff-9879d6db96fd29134fc802214163b95a Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb')
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
new file mode 100644
index 0000000000..25c2ce81f8
--- /dev/null
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
@@ -0,0 +1,46 @@
+SUMMARY = "A font editor"
+HOMEPAGE = "http://fontforge.github.io/en-US/"
+LICENSE = "BSD-3-Clause & GPLv3"
+LIC_FILES_CHKSUM = " \
+ file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSE;md5=d042f3d2a8fd7208b704a499168e3c89 \
+"
+
+DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gettext-native"
+DEPENDS_append_class-target = " libxi"
+
+inherit autotools pkgconfig pythonnative distro_features_check gettext gtk-icon-cache mime
+
+REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
+
+# tag 20190801
+SRCREV = "ac635b818e38ddb8e7e2e1057330a32b4e25476e"
+SRC_URI = "git://github.com/${BPN}/${BPN}.git \
+ file://0001-include-sys-select-on-non-glibc-platforms.patch \
+"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF += "--without-libuninameslist"
+EXTRA_OECONF_append_class-native = " with_x=no"
+
+#do_configure_prepend() {
+# uthash sources are expected in uthash/src
+# mkdir -p ${S}/uthash/src
+# cp ${STAGING_INCDIR}/ut*.h ${S}/uthash/src
+#}
+
+PACKAGES =+ "${PN}-python"
+
+RPROVIDES_${PN}-dbg += "${PN}-python-dbg"
+
+FILES_${PN} += " \
+ ${datadir}/appdata \
+ ${datadir}/metainfo \
+ ${datadir}/mime \
+"
+
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
+RDEPENDS_${PN}-python = "python"
+
+# for e.g kde's oxygen-fonts
+BBCLASSEXTEND = "native"