aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs/nodejs_16.18.1.bb
diff options
context:
space:
mode:
authorArchana Polampalli <archana.polampalli@windriver.com>2022-12-20 05:43:23 +0000
committerArmin Kuster <akuster808@gmail.com>2022-12-20 10:00:29 -0500
commit1c7063e57d576b9dcb266837c5d7204ce28968f2 (patch)
tree9e47e61538d03967c51d97a16929953e51a9f577 /meta-oe/recipes-devtools/nodejs/nodejs_16.18.1.bb
parent98097845bdc4d1797346cb1245da6abe59bfef2f (diff)
downloadmeta-openembedded-1c7063e57d576b9dcb266837c5d7204ce28968f2.tar.gz
Nodejs: Fixed python3 DeprecationWarning
Distutils package and pipes are deprecated and slated for removal in Python 3.13 for Nodejs 16.18 Replaced distutils with setuptools Signed-off-by: Archana Polampalli <archana.polampalli@windriver.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs/nodejs_16.18.1.bb')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_16.18.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_16.18.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_16.18.1.bb
index a67948320d..e755d0c9aa 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_16.18.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_16.18.1.bb
@@ -7,7 +7,7 @@ DEPENDS = "openssl"
DEPENDS:append:class-target = " qemu-native"
DEPENDS:append:class-native = " c-ares-native"
-inherit pkgconfig python3native qemu
+inherit pkgconfig python3native qemu setuptools3
COMPATIBLE_MACHINE:armv4 = "(!.*armv4).*"
COMPATIBLE_MACHINE:armv5 = "(!.*armv5).*"
@@ -25,6 +25,7 @@ SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
file://system-c-ares.patch \
file://0001-liftoff-Correct-function-signatures.patch \
file://0001-mips-Use-32bit-cast-for-operand-on-mips32.patch \
+ file://0001-Nodejs-Fixed-pipes-DeprecationWarning.patch \
"
SRC_URI:append:class-target = " \
file://0001-Using-native-binaries.patch \