aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/android-tools
diff options
context:
space:
mode:
authorBen Brown <ben.brown@codethink.co.uk>2021-08-02 17:23:27 +0100
committerKhem Raj <raj.khem@gmail.com>2021-08-03 08:53:04 -0700
commit3f36657af2a203ef77acbff7b0c5be4098c67f25 (patch)
tree05e57a9c1107985cd652dbcf0a0a90a548caebe5 /meta-oe/recipes-devtools/android-tools
parentf0b8ee3702ab8632fc4710c76a6643357ae9185f (diff)
downloadmeta-openembedded-3f36657af2a203ef77acbff7b0c5be4098c67f25.tar.gz
android-tools: fix install of adb client when TOOLS is overridden
Overriding TOOLS with 'adb' as the only entry, or with 'adb' as the final entry in the list fails to match the grep pattern. The current pattern includes trailing whitespace, likely to distinguish it from 'adbd'. However since `${TOOLS}` is then passed to grep unquoted, any trailing whitespace would be dropped by the shell. Fixed by replacing the trailing whitespace with '\>' to mark the end of the word, which continues to ensure we don't match against 'adbd'. Signed-off-by: Ben Brown <ben.brown@codethink.co.uk> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/android-tools')
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index e8992346b0..fc91e13a55 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -133,7 +133,7 @@ do_install() {
install -m0755 ${B}/ext4_utils/simg2simg ${D}${bindir}
fi
- if echo ${TOOLS} | grep -q "adb " ; then
+ if echo ${TOOLS} | grep -q "adb\>" ; then
install -d ${D}${bindir}
install -m0755 ${B}/adb/adb ${D}${bindir}
fi