aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorStefan Schmidt <stefan.schmidt@huawei.com>2021-03-18 20:32:35 +0100
committerKhem Raj <raj.khem@gmail.com>2021-03-18 12:43:41 -0700
commitad220639ddb67648d3eb9ddf536613d5999c1e2a (patch)
tree483f0677e09291103544a8cae996e7f2de1d32e2 /meta-oe/recipes-core
parent60d58ceb8f51d5807fd6147f404cfbea69df8523 (diff)
downloadmeta-openembedded-ad220639ddb67648d3eb9ddf536613d5999c1e2a.tar.gz
musl-rpmatch_git.bb: add new recipe to provide rpmatch() for musl libc builds
Musl does not provide rpmatch() while glibc does. This is a standalone implementation for musl libc based systems. Using it for a recipe is as simple as adding the dependency and adding -lrpmatch to the LDFLAGS for linking. An example for plymouth is provided as follow up patch. Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/musl-rpmatch/musl-rpmatch_git.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/musl-rpmatch/musl-rpmatch_git.bb b/meta-oe/recipes-core/musl-rpmatch/musl-rpmatch_git.bb
new file mode 100644
index 0000000000..553003f7f7
--- /dev/null
+++ b/meta-oe/recipes-core/musl-rpmatch/musl-rpmatch_git.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Implementation of rpmatch(3) for musl libc."
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=81a81bf31abecc50c20862fc8a716329"
+
+SRC_URI = "gitsm://github.com/pullmoll/musl-rpmatch.git;protocol=https"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "46267b154987d3e1f25d3a75423faa62bb5ee342"
+
+inherit autotools
+
+S = "${WORKDIR}/git"