aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-11-26 18:25:35 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-26 10:33:56 -0800
commit56101d3e3bbed0ae25cc809e288e8d25ff2575c5 (patch)
tree34589f24d6abc4e26bcadc2929550b4cab5fa3f8 /meta-oe/recipes-benchmark
parent2c54b53159393b20c64894327b39610826ddaaf9 (diff)
downloadmeta-openembedded-56101d3e3bbed0ae25cc809e288e8d25ff2575c5.tar.gz
glmark2: use Python 3 to build
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2/python3.patch12
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2/python3.patch b/meta-oe/recipes-benchmark/glmark2/glmark2/python3.patch
new file mode 100644
index 0000000000..df208cf878
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2/python3.patch
@@ -0,0 +1,12 @@
+Use Python 3 instead of Python 2.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/waf b/waf
+index 6ce2a24..de3c898 100755
+--- a/waf
++++ b/waf
+@@ -1 +1 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 8b767463bf..50b553c807 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -14,7 +14,8 @@ PV = "20190904+${SRCPV}"
COMPATIBLE_HOST_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '.*-linux*', 'null', d)}"
-SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https"
+SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
+ file://python3.patch"
SRCREV = "24a1139dcbfd86bd02065316eaa90559e39374e1"
S = "${WORKDIR}/git"