aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gdm/gdm/cross-xdetection.diff
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-08 17:56:00 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-08 17:56:00 +0200
commitf5b2fa5ea2d80e971fa5ca25b33771a503a0a54a (patch)
treea0f7927d3adcfd4d78c877e84ae554757a177c84 /meta-gnome/recipes-gnome/gdm/gdm/cross-xdetection.diff
parent9f2c190edefe923afe664e5fc86de5f9ed9486c6 (diff)
downloadmeta-openembedded-f5b2fa5ea2d80e971fa5ca25b33771a503a0a54a.tar.gz
gdm 2.30.0: import from OE rev d4f0211e2078d5033ae0dee74664de5520d8392d
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/gdm/gdm/cross-xdetection.diff')
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm/cross-xdetection.diff84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gdm/gdm/cross-xdetection.diff b/meta-gnome/recipes-gnome/gdm/gdm/cross-xdetection.diff
new file mode 100644
index 0000000000..9cb6ac98dd
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gdm/gdm/cross-xdetection.diff
@@ -0,0 +1,84 @@
+--- /tmp/configure.ac 2008-12-10 08:38:16.000000000 +0100
++++ gdm-2.24.1/configure.ac 2008-12-10 08:39:17.000000000 +0100
+@@ -1133,80 +1133,10 @@
+ dnl - Check for X Server location
+ dnl ---------------------------------------------------------------------------
+
+-# First check with "! -h" for /usr/X11R6 and /usr/X11 since they often
+-# symlink to each other, and configure should use the more stable
+-# location (the real directory) if possible.
+-#
+-# On Solaris, the /usr/bin/Xserver script is used to decide whether to
+-# use Xsun or Xorg, so this is used on Solaris.
+-#
+-# When testing for /usr/X11R6, first check with "! -h" for /usr/X11R6
+-# and /usr/X11 since they often symlink to each other, and configure
+-# should use the more stable location (the real directory) if possible.
+-#
+-if test -x /usr/X11/bin/Xserver; then
+- X_PATH="/usr/X11/bin"
+- X_SERVER_PATH="/usr/X11/bin"
+- X_SERVER="/usr/X11/bin/Xserver"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test ! -h /usr/X11R6 -a -x /usr/X11R6/bin/X; then
+- X_PATH="/usr/X11R6/bin"
+- X_SERVER_PATH="/usr/X11R6/bin"
+- X_SERVER="/usr/X11R6/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11R6/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test ! -h /usr/X11 -a -x /usr/X11/bin/X; then
+- X_PATH="/usr/X11/bin"
+- X_SERVER_PATH="/usr/X11/bin"
+- X_SERVER="/usr/X11/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/X11R6/bin/X; then
+- X_PATH="/usr/X11R6/bin"
+- X_SERVER_PATH="/usr/X11R6/bin"
+- X_SERVER="/usr/X11R6/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11R6/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/bin/Xorg; then
+ X_PATH="/usr/bin"
+ X_SERVER_PATH="/usr/bin"
+- X_SERVER="/usr/bin/Xorg"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/X11/bin/X; then
+- X_PATH="/usr/X11/bin"
+- X_SERVER_PATH="/usr/X11/bin"
+- X_SERVER="/usr/X11/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/openwin/bin/Xsun; then
+- # Do not add /usr/openwin/bin here because on Solaris you need
+- # /usr/openwin/bin in your PATH even if you are using the Xorg
+- # Xserver. We add this to the path below.
+- X_PATH="/usr/openwin/bin"
+- X_SERVER_PATH="/usr/openwin/bin"
+- X_SERVER="/usr/openwin/bin/Xsun"
+- X_CONFIG_OPTIONS="-audit 0 -nobanner"
+-elif test -x /opt/X11R6/bin/X; then
+- X_PATH="/opt/X11R6/bin"
+- X_SERVER_PATH="/opt/X11R6/bin"
+- X_SERVER="/opt/X11R6/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/opt/X11R6/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/bin/X; then
+- X_PATH="/usr/bin"
+- X_SERVER_PATH="/usr/bin"
+- X_SERVER="/usr/bin/X"
+- X_CONFIG_OPTIONS="-audit 0"
+-else
+- # what to do, what to do, this is wrong, but this just sets the
+- # defaults, perhaps this user is cross compiling or some such
+- X_PATH="/usr/bin/X11:/usr/X11R6/bin:/opt/X11R6/bin"
+- X_SERVER_PATH="/usr/X11R6/bin"
+- X_SERVER="/usr/X11R6/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/bin/X11:/usr/X11R6/bin:/usr/local/bin:/opt/X11R6/bin"
++ X_SERVER="/etc/X11/Xserver"
+ X_CONFIG_OPTIONS="-audit 0"
+-fi
+
+ # Don't add bindir to GDM_USER_PATH if it is already in the PATH.
+ # If it is /bin or /usr/bin, for example.