aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-connectivity
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-01-20 21:26:42 +0100
committerKhem Raj <raj.khem@gmail.com>2022-01-25 09:13:09 -0800
commit5b73a63ea08665a15256d0f0efcc7be886e3d863 (patch)
tree90ed4ca0af3c63bad1eb235d5fd049fe86df62ac /meta-gnome/recipes-connectivity
parent5a3b14466783def52b855f0e079f9b346b0021a8 (diff)
downloadmeta-openembedded-5b73a63ea08665a15256d0f0efcc7be886e3d863.tar.gz
geary: initial add recipe
Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-connectivity')
-rw-r--r--meta-gnome/recipes-connectivity/geary/geary_40.0.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
new file mode 100644
index 0000000000..e4d07ad293
--- /dev/null
+++ b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
@@ -0,0 +1,54 @@
+SUMMARY = "Geary is an email application built around conversations, for the GNOME 3 desktop."
+SECTION = "network"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2a2244d5a13871ad950c55877546a6a2"
+
+DEPENDS = " \
+ appstream-glib \
+ cairo \
+ enchant2 \
+ evolution-data-server \
+ folks \
+ gcr \
+ gmime \
+ gnome-online-accounts \
+ gsound \
+ gspell \
+ gtk+3 \
+ icu \
+ iso-codes \
+ json-glib \
+ libhandy \
+ libical \
+ libpeas \
+ libsecret \
+ libstemmer \
+ libxml2 \
+ sqlite3 \
+ webkitgtk \
+"
+
+RDEPENDS:${PN} = "gnome-keyring"
+
+inherit meson pkgconfig mime-xdg gtk-icon-cache gobject-introspection vala
+
+SRC_URI = " \
+ git://github.com/GNOME/geary.git;nobranch=1;protocol=https \
+"
+
+S = "${WORKDIR}/git"
+SRCREV = "gnome-${PV}"
+
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+
+GIR_MESON_OPTION = ""
+EXTRA_OEMESON = "-Dprofile=release"
+
+PACKAGECONFIG[libunwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
+PACKAGECONFIG[tnef] = "-Dtnef=enabled,-Dtnef=disabled,libytnef"
+PACKAGECONFIG[valadoc] = "-Dvaladoc=enabled,-Dvaladoc=disabled"
+
+PACKAGECONFIG ??= ""
+
+FILES:${PN} += "${datadir}"
+