aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2019-12-02 19:33:39 +0000
committerKhem Raj <raj.khem@gmail.com>2019-12-03 09:31:53 -0800
commitf6df0263f768108db5c5b8c098ef0d4c699841a4 (patch)
tree4daa806b8fe099b7a9e18a523cebdc9a102d2a9f
parentd93da893d281d7d817cfef59695c831c5cfc0270 (diff)
downloadmeta-openembedded-f6df0263f768108db5c5b8c098ef0d4c699841a4.tar.gz
ostree: Fix DISTRO_FEATURES with ptest but w/o xattr
Fix the test for PTEST_ENABLED so it only fires when it's actually enabled, as opposed to everytime. This allows the tautological test for native to be removed as PTEST_ENABLED isn't set there. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2019.5.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2019.5.bb b/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
index b3b34a15e6..b2bfaaf051 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
@@ -182,8 +182,8 @@ SYSTEMD_SERVICE_${PN}-switchroot = "ostree-prepare-root.service"
BBCLASSEXTEND = "native"
python __anonymous() {
- if not bb.data.inherits_class('native', d) and bb.utils.contains('PTEST_ENABLED', '1', 'True', 'False', d):
- if not bb.utils.contains_any('BBFILE_COLLECTIONS', 'meta-python', 'True', 'False', d):
+ if bb.utils.contains('PTEST_ENABLED', '1', 'True', '', d):
+ if not bb.utils.contains_any('BBFILE_COLLECTIONS', 'meta-python', 'True', '', d):
raise bb.parse.SkipRecipe('ptest requires meta-python to be present.')
elif not bb.utils.contains_any('PACKAGECONFIG', 'soup curl', 'True', 'False', d):
raise bb.parse.SkipRecipe('ptest requires soup enabled in PACKAGECONFIG.')