aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-03 12:57:56 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-06 10:26:40 -0700
commited796b822f31fe1da381d1e2b85d2c86926a4844 (patch)
treeed619876ba7b1303b994509824716960f9ff86d0
parent72467cbf880df33d358322067caeee515107f42e (diff)
downloadmeta-openembedded-ed796b822f31fe1da381d1e2b85d2c86926a4844.tar.gz
python3-pyalsaaudio: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyalsaaudio.inc11
-rw-r--r--meta-python/recipes-devtools/python/python3-pyalsaaudio_0.8.4.bb13
2 files changed, 12 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyalsaaudio.inc b/meta-python/recipes-devtools/python/python-pyalsaaudio.inc
deleted file mode 100644
index d150409a2a..0000000000
--- a/meta-python/recipes-devtools/python/python-pyalsaaudio.inc
+++ /dev/null
@@ -1,11 +0,0 @@
-SUMMARY = "Support for the Linux 2.6.x ALSA Sound System"
-SECTION = "devel/python"
-LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1a3b161aa0fcec32a0c8907a2219ad9d"
-
-SRC_URI[md5sum] = "b46f69561bc85fc52e698b2440ca251e"
-SRC_URI[sha256sum] = "84e8f8da544d7f4bd96479ce4a237600077984d9be1d7f16c1d9a492ecf50085"
-
-DEPENDS += "alsa-lib"
-
-RDEPENDS_${PN} += "libasound"
diff --git a/meta-python/recipes-devtools/python/python3-pyalsaaudio_0.8.4.bb b/meta-python/recipes-devtools/python/python3-pyalsaaudio_0.8.4.bb
index b7da1a43d8..987010a142 100644
--- a/meta-python/recipes-devtools/python/python3-pyalsaaudio_0.8.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyalsaaudio_0.8.4.bb
@@ -1,2 +1,13 @@
-require python-pyalsaaudio.inc
+SUMMARY = "ALSA bindings"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1a3b161aa0fcec32a0c8907a2219ad9d"
+
inherit pypi setuptools3
+
+SRC_URI[md5sum] = "b46f69561bc85fc52e698b2440ca251e"
+SRC_URI[sha256sum] = "84e8f8da544d7f4bd96479ce4a237600077984d9be1d7f16c1d9a492ecf50085"
+
+DEPENDS += "alsa-lib"
+
+RDEPENDS_${PN} += "libasound"