aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlater, Joseph <joe.slater@windriver.com>2020-07-21 15:00:55 -0700
committerKhem Raj <raj.khem@gmail.com>2020-07-21 16:46:37 -0700
commitd4c6f65de79211310380704df63f0c9a18fb9d48 (patch)
tree1f7a4b1d4fc43d175dd4c07953879d5fb3fad33e
parent75ec95b17c048d99f7d8e64e42ad82b6074f39cd (diff)
downloadmeta-openembedded-d4c6f65de79211310380704df63f0c9a18fb9d48.tar.gz
toybox-inittab: unpack to S
toybox-inittab does not unpack source files into S, so the archiver cannot see them. We copy them to a sub-directory in order to keep the originals available if running do_configure() (again) without first running do_unpack(). Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
index 9af1e3f149..f82f8e9ce2 100644
--- a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
+++ b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
@@ -2,10 +2,12 @@ SUMMARY = "Toybox Inittab Configuration"
LICENSE = "BSD-0-Clause"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-0-Clause;md5=81eeb0083e31f11ab1e33ded846d521c"
+# Unpack to ${S}/orig
+#
SRC_URI = "\
- file://inittab \
- file://rcK \
- file://rcS \
+ file://inittab;subdir=${BP}/orig \
+ file://rcK;subdir=${BP}/orig \
+ file://rcS;subdir=${BP}/orig \
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -15,6 +17,9 @@ RCONFLICTS_${PN} = "\
sysvinit-inittab \
"
+# Just being sure.
+B = "${S}"
+
# most users may want to have getty enabled by default
PACKAGECONFIG ??= "getty"
@@ -26,9 +31,7 @@ do_patch[noexec] = "1"
do_configure() {
# copy over files now to have a fresh start on each config
- for f in inittab rcK rcS; do
- cp ${WORKDIR}/$f ${S}
- done
+ cp orig/* .
for config in ${PACKAGECONFIG_CONFARGS}; do
if [[ ${config} == "enable_getty" ]]; then