aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:14 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:34 -0800
commit8667e7db0f48120b39a5cba8519d68835212f87d (patch)
tree7cc8cfb5c9aeb7f312ab0ea96c13bdff731699be
parenta55a9b65f4c553a27533ab3a671149c44ff28566 (diff)
downloadmeta-openembedded-8667e7db0f48120b39a5cba8519d68835212f87d.tar.gz
python3-dnspython: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb19
2 files changed, 11 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dnspython/run-ptest b/meta-python/recipes-devtools/python/python3-dnspython/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-dnspython/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-dnspython/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb
index 6b7212b9b5..c5c8d42e2d 100644
--- a/meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb
@@ -12,7 +12,8 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {
@@ -21,15 +22,15 @@ do_install_ptest() {
}
DEPENDS += "\
- ${PYTHON_PN}-wheel-native \
- ${PYTHON_PN}-setuptools-scm-native \
+ python3-wheel-native \
+ python3-setuptools-scm-native \
"
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-crypt \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-math \
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-threading \
+ python3-crypt \
+ python3-io \
+ python3-math \
+ python3-netclient \
+ python3-numbers \
+ python3-threading \
"