aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-11-11 23:14:17 +0800
committerKhem Raj <raj.khem@gmail.com>2021-11-11 08:31:56 -0800
commit799dc735f830a656b0a04308d878cb8a147ef0be (patch)
tree3d49c12093d5bc3a633c120d733c8525eacfcd08
parent4aa6b803edc7d99bf9ca9cd36bc29cdfb10ed10d (diff)
downloadmeta-openembedded-799dc735f830a656b0a04308d878cb8a147ef0be.tar.gz
strongswan: add required kernel modules to RRECOMMENDS
Strongswan failed to startup because there is no kernel module named ipsec. Add basic kernel modules required by strongswan per [1]. [1] https://wiki.strongswan.org/projects/strongswan/wiki/KernelModules, Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb b/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
index cbc263d301..45500df01c 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
@@ -47,7 +47,10 @@ PACKAGECONFIG[systemd-charon] = "--enable-systemd,--disable-systemd,systemd,"
inherit autotools systemd pkgconfig
-RRECOMMENDS:${PN} = "kernel-module-ipsec"
+RRECOMMENDS:${PN} = "kernel-module-ah4 \
+ kernel-module-esp4 \
+ kernel-module-xfrm-user \
+ "
FILES:${PN} += "${libdir}/ipsec/lib*${SOLIBS}"
FILES:${PN}-dbg += "${bindir}/.debug ${sbindir}/.debug ${libdir}/ipsec/.debug ${libexecdir}/ipsec/.debug"