aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin McAllister <colinmca242@gmail.com>2020-07-22 15:07:20 +0000
committerKhem Raj <raj.khem@gmail.com>2020-07-23 10:26:39 -0700
commit76103526779b532486cce403b4712bfb609a022f (patch)
treee2d23d8a05dead8b9e7334b6304ee4c8ac58941d
parentd6bd2fc61359b6cdf4179f6be077691732df2c14 (diff)
downloadmeta-openembedded-76103526779b532486cce403b4712bfb609a022f.tar.gz
python3-bitstruct: Added recipe
Created python3 recipe for bitstruct. Signed-off-by: Colin McAllister <colinmca242@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-bitstruct_8.11.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitstruct_8.11.0.bb b/meta-python/recipes-devtools/python/python3-bitstruct_8.11.0.bb
new file mode 100644
index 0000000000..a25380418c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bitstruct_8.11.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "This module performs conversions between Python values and C bit field structs represented as Python byte strings."
+HOMEPAGE = "https://github.com/eerimoq/bitstruct"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
+
+SRC_URI[md5sum] = "8eaf853c95e10ca4b6bca2fe5ff307c6"
+SRC_URI[sha256sum] = "2b13f2c3e76b49e8cd854f7a1da590bb73ecbc6cbfacc2d479eacf2b88282d5d"
+
+PYPI_PACKAGE = "bitstruct"
+
+inherit pypi setuptools3
+
+CLEANBROKEN = "1"
+