aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Carvalho <andrestc@fb.com>2020-07-02 10:12:27 -0700
committerKhem Raj <raj.khem@gmail.com>2020-07-02 15:34:39 -0700
commit752654120927f635c52b53229a0dbf6d04856e44 (patch)
treead4d2731123a9e6e718696952bc4349173471a03
parent93aa8defe3fae48c48b364136a0af8a58fd2be95 (diff)
downloadmeta-openembedded-752654120927f635c52b53229a0dbf6d04856e44.tar.gz
netcat: Set CVE_PRODUCT
This way yocto cve-check can find open CVE's. See also: http://lists.openembedded.org/pipermail/openembedded-core/2017-July/139897.html "Results from cve-check are not very good at the moment. One of the reasons for this is that component names used in CVE database differ from yocto recipe names. This series fixes several of those name mapping problems by setting the CVE_PRODUCT correctly in the recipes. To check this mapping with after a build, I'm exporting LICENSE and CVE_PRODUCT variables to buildhistory for recipes and packages." Value added is based on: https://nvd.nist.gov/products/cpe/search/results?keyword=netcat&status=FINAL&orderBy=CPEURI&namingFormat=2.3 Signed-off-by: Andre Carvalho <andrestc@fb.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/netcat/netcat_0.7.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat_0.7.1.bb b/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
index 14d743f820..1e113de519 100644
--- a/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
+++ b/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
@@ -16,6 +16,8 @@ SRC_URI[sha256sum] = "b55af0bbdf5acc02d1eb6ab18da2acd77a400bafd074489003f3df0967
inherit autotools
+CVE_PRODUCT = "netcat_project:netcat"
+
do_install_append() {
install -d ${D}${bindir}
mv ${D}${bindir}/nc ${D}${bindir}/nc.${BPN}