aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-06 12:45:46 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-06 20:57:44 -0700
commit3c259f977e8647ac9c54097d0faab70719a5553e (patch)
treec9194f4bcff2dfc6ca7d4eb940e629fce70ba8af
parent5f3f16214532f489e46f1cb4f506727a26c0a359 (diff)
downloadmeta-openembedded-3c259f977e8647ac9c54097d0faab70719a5553e.tar.gz
icewm: Upgrade to 2.3.3
Do not check for C++11, since it is a runtime check, wont work during cross compile, in anycase our compilers do support C++11 and default to c++ or newer std, so this check is redundant for OE toolchains Add new required build time deps on fribidi and imlib2 Changes are [1] [1] https://github.com/ice-wm/icewm/releases/tag/2.3.3 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch31
-rw-r--r--meta-oe/recipes-extended/icewm/icewm_2.3.3.bb (renamed from meta-oe/recipes-extended/icewm/icewm_1.6.5.bb)4
2 files changed, 26 insertions, 9 deletions
diff --git a/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch b/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch
index 7943948550..c5e210afcd 100644
--- a/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch
+++ b/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch
@@ -10,11 +10,9 @@ Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index c5e3ca03..4b89396a 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -140,7 +140,7 @@ AC_CHECK_FUNC([getloadavg],[AC_DEFINE([HAVE_GETLOADAVG2], 1, [getloadavg() is av
+@@ -160,7 +160,7 @@ AC_CHECK_FUNCS([backtrace_symbols_fd mem
AC_FUNC_SELECT_ARGTYPES
AC_MSG_CHECKING([for strlcpy])
@@ -23,7 +21,7 @@ index c5e3ca03..4b89396a 100644
char a[2];
if (strlcpy(a, "yes", 2) != 3)
return 1;]])],
-@@ -156,7 +156,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <string.h>]],[[
+@@ -176,7 +176,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[#includ
])
AC_MSG_CHECKING([for strlcat])
@@ -32,6 +30,25 @@ index c5e3ca03..4b89396a 100644
char a[4] = "no";
if (strlcat(a, "yes", 4) != 5)
return 1;]])],
---
-2.17.1
-
+@@ -191,21 +191,6 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[#includ
+ [Define to 1 if you have the strlcat function.])
+ ])
+
+-AC_MSG_CHECKING([for C++11 by default])
+-AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <regex>]],[[
+- if (__cplusplus < 201103L) return 1;]])],
+- [AC_MSG_RESULT([yes])],
+- [AC_MSG_RESULT([no])
+- AC_MSG_CHECKING([for C++11 when forced])
+- CXXFLAGS="$CXXFLAGS -std=c++11"
+- AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <regex>]],[[
+- if (__cplusplus < 201103L) return 1;]])],
+- [AC_MSG_RESULT([yes])],
+- [AC_MSG_RESULT([no])
+- AC_MSG_ERROR([Need C++11. Please set CXXFLAGS.])
+- ])
+- ])
+-
+ PKG_CHECK_MODULES([CORE],[fontconfig xrender xcomposite xdamage xfixes xext x11])
+ AC_SUBST([CORE_CFLAGS])
+ AC_SUBST([CORE_LIBS])
diff --git a/meta-oe/recipes-extended/icewm/icewm_1.6.5.bb b/meta-oe/recipes-extended/icewm/icewm_2.3.3.bb
index 241a2b30f3..abc3e098c5 100644
--- a/meta-oe/recipes-extended/icewm/icewm_1.6.5.bb
+++ b/meta-oe/recipes-extended/icewm/icewm_2.3.3.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4a26952467ef79a7efca4a9cf52d417b"
SRC_URI = "https://github.com/ice-wm/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.lz \
file://0001-configure.ac-skip-running-test-program-when-cross-co.patch \
"
-SRC_URI[sha256sum] = "d41e6abf842ff3f8705a81d352be7c5b181c587549c183de0641c3820234a7b2"
+SRC_URI[sha256sum] = "4162565cf7566d78d786e4ecf4b0639451b8464bcb24e761b1f08ef43e95e513"
UPSTREAM_CHECK_URI = "https://github.com/ice-wm/${BPN}/releases"
@@ -19,7 +19,7 @@ EXTRA_OECONF += "--with-libdir=${datadir}/icewm \
--enable-xinerama \
--enable-shape"
-DEPENDS = "asciidoc-native fontconfig gdk-pixbuf libxft libxpm libxrandr \
+DEPENDS = "asciidoc-native fontconfig fribidi gdk-pixbuf imlib2 libxft libxpm libxrandr \
libxinerama libice libsm libx11 libxext libxrender libxcomposite libxdamage \
libxfixes"
DEPENDS_append = " qemu-native"