aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin McAllister <colinmca242@gmail.com>2020-07-22 20:33:55 +0000
committerKhem Raj <raj.khem@gmail.com>2020-08-11 09:42:55 -0700
commit3b2c058ca988fcbf643567cf75082ca374ded1b4 (patch)
treeaaca3d3df2f9195bbca969d4420a331cf36c0422
parentf9617f1f8ad8f84908077e636a6298cd39213407 (diff)
downloadmeta-openembedded-3b2c058ca988fcbf643567cf75082ca374ded1b4.tar.gz
python3-pynacl: Added recipe
Created Python3 recipe for PyNaCl. Signed-off-by: Colin McAllister <colinmca242@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pynacl_1.4.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pynacl_1.4.0.bb b/meta-python/recipes-devtools/python/python3-pynacl_1.4.0.bb
new file mode 100644
index 0000000000..6fd42ebf81
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pynacl_1.4.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
+DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library"
+HOMEPAGE = "https://github.com/pyca/pynacl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
+
+SRC_URI[md5sum] = "8c6c57893327a694c72510fb620e4744"
+SRC_URI[sha256sum] = "54e9a2c849c742006516ad56a88f5c74bf2ce92c9f67435187c3c5953b346505"
+
+PYPI_PACKAGE = "PyNaCl"
+
+inherit pypi setuptools3
+
+DEPENDS += "\
+ ${PYTHON_PN}-wheel-native \
+ ${PYTHON_PN}-cffi-native \
+ libsodium \
+"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-cffi \
+ libsodium \
+"
+
+do_compile_prepend() {
+ export SODIUM_INSTALL=system
+}
+
+do_install_prepend() {
+ export SODIUM_INSTALL=system
+}