aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-11-06 09:53:10 +0800
committerArmin Kuster <akuster808@gmail.com>2024-01-05 07:52:16 -0500
commitcf4a2fa949c77ae207af766fde02a6ec5e29a779 (patch)
treef75927c3e1aa2b1c7723b98348c2a81ab83547e0
parent1092d94bbe5c631da144e9844d1f6eceaf8d1eaa (diff)
downloadmeta-openembedded-cf4a2fa949c77ae207af766fde02a6ec5e29a779.tar.gz
hdf5: Fix install conflict when enable multilib.
Error: Transaction test error: file /usr/bin/h5cc conflicts between attempted installs of lib32-hdf5-1.14.2-r0.armv7ahf_neon and hdf5-1.14.2-r0.cortexa57 file /usr/bin/h5hlcc conflicts between attempted installs of lib32-hdf5-1.14.2-r0.armv7ahf_neon and hdf5-1.14.2-r0.cortexa57 The differences of h5cc are as follows: @@ -44,7 +44,7 @@ exit $status ;; *) - /usr/bin/arm-pokymllib32-linux-gnueabi/arm-pokymllib32-linux-gnueabi-clang $@ `pkg-config --define-variable=prefix=$dir --cflags --libs hdf5` + /usr/bin/aarch64-poky-linux/aarch64-poky-linux-clang $@ `pkg-config --define-variable=prefix=$dir --cflags --libs hdf5` status=$? exit $status ;; The differences of h5hlcc are as follows: @@ -44,7 +44,7 @@ exit $status ;; *) - /usr/bin/arm-pokymllib32-linux-gnueabi/arm-pokymllib32-linux-gnueabi-clang $@ `pkg-config --define-variable=prefix=$dir --cflags --libs hdf5_hl` + /usr/bin/aarch64-poky-linux/aarch64-poky-linux-clang $@ `pkg-config --define-variable=prefix=$dir --cflags --libs hdf5_hl` status=$? exit $status ;; Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit fc7666e5bc01ddcdc16d9d3b838be5c35d84fda2) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/hdf5/hdf5_1.14.2.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/hdf5/hdf5_1.14.2.bb b/meta-oe/recipes-support/hdf5/hdf5_1.14.2.bb
index 68b91c0b0c..e716430673 100644
--- a/meta-oe/recipes-support/hdf5/hdf5_1.14.2.bb
+++ b/meta-oe/recipes-support/hdf5/hdf5_1.14.2.bb
@@ -7,7 +7,7 @@ SECTION = "libs"
LICENSE = "HDF5"
LIC_FILES_CHKSUM = "file://COPYING;md5=9ba0f3d878ab6c2403c86e9b0362d998"
-inherit cmake siteinfo qemu multilib_header
+inherit cmake siteinfo qemu multilib_header multilib_script
DEPENDS += "qemu-native zlib"
@@ -40,6 +40,10 @@ EOF
do_unpack[postfuncs] += "gen_emu"
+MULTILIB_SCRIPTS += "${PN}:${bindir}/h5cc \
+ ${PN}:${bindir}/h5hlcc \
+"
+
do_install:append() {
# Used for generating config files on target
install -m 755 ${B}/bin/H5detect ${D}${bindir}