aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2021-12-03 21:39:14 +0100
committerKhem Raj <raj.khem@gmail.com>2021-12-06 09:56:50 -0800
commitf0b4e37b77efe727cf2b3288256609eae8ceb119 (patch)
treeb79c83b5bd733d631c1da554bbd32639c0827625
parent4a53cdded70957b1fd77169aefb7307dcf0602e0 (diff)
downloadmeta-openembedded-f0b4e37b77efe727cf2b3288256609eae8ceb119.tar.gz
gattlib: Explicitly disable Python support
Under some configuration, CMake may pick up the existence of python from the native recipe sysroot and use that when linking for target, resulting in the following error: ld: .../recipe-sysroot-native/usr/lib/libpython3.10.so: error adding symbols: file in wrong format Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/gattlib/gattlib_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb b/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
index ecff79be45..3fe4c9404c 100644
--- a/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
+++ b/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
@@ -23,6 +23,7 @@ PACKAGECONFIG[examples] = "-DGATTLIB_BUILD_EXAMPLES=ON,-DGATTLIB_BUILD_EXAMPLES=
# Set this to force use of DBus API if Bluez version is older than 5.42
PACKAGECONFIG[force-dbus] = "-DGATTLIB_FORCE_DBUS=TRUE,-DGATTLIB_FORCE_DBUS=FALSE"
+EXTRA_OECMAKE += "-DGATTLIB_PYTHON_INTERFACE=OFF"
EXTRA_OECMAKE += "-DGATTLIB_BUILD_DOCS=OFF"
inherit pkgconfig cmake