aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-09 00:57:10 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-23 15:49:38 +0200
commitc9a07b63e3268e4b8d04c6917d8cd131e019e65c (patch)
treea46c7d26d5a99b9c9296272c667298dd211e6679
parentc8044261026113b0d2769fce9eba6cdfffe89a95 (diff)
downloadmeta-openembedded-c9a07b63e3268e4b8d04c6917d8cd131e019e65c.tar.gz
libsdl2-ttf: Check for x11 and opengl in distro features
when X11 is not in distro features it tries to link with libGL which does not exist and compile fails Add a patch to add foreign option to AUTOMAKE_OPTIONS which lets it configure and relax automake rules to not check for some GNU specific files Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/files/automake_foreign.patch13
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf_2.0.14.bb11
2 files changed, 20 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/libsdl-ttf/files/automake_foreign.patch b/meta-oe/recipes-support/libsdl-ttf/files/automake_foreign.patch
new file mode 100644
index 0000000000..2d5bd6d910
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/files/automake_foreign.patch
@@ -0,0 +1,13 @@
+Index: SDL2_ttf-2.0.14/Makefile.am
+===================================================================
+--- SDL2_ttf-2.0.14.orig/Makefile.am
++++ SDL2_ttf-2.0.14/Makefile.am
+@@ -1,6 +1,8 @@
+ # Makefile.am for the SDL truetype font loading library and viewer
+ lib_LTLIBRARIES = libSDL2_ttf.la
+
++AUTOMAKE_OPTIONS = foreign
++
+ libSDL2_ttfincludedir = $(includedir)/SDL2
+ libSDL2_ttfinclude_HEADERS = \
+ SDL_ttf.h
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf_2.0.14.bb b/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf_2.0.14.bb
index f2441f9cfc..4601593ad8 100644
--- a/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf_2.0.14.bb
+++ b/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf_2.0.14.bb
@@ -1,23 +1,25 @@
SUMMARY = "Simple DirectMedia Layer truetype font library"
SECTION = "libs"
-DEPENDS = "virtual/libsdl2 freetype"
+DEPENDS = "virtual/libsdl2 freetype virtual/libgl"
LICENSE = "Zlib"
LIC_FILES_CHKSUM = "file://COPYING.txt;md5=cb33e7c4df9fbde389f149ad6bc93ce5"
SRC_URI = " \
http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-${PV}.tar.gz \
file://use.pkg-config.for.freetype2.patch \
+ file://automake_foreign.patch \
"
SRC_URI[md5sum] = "e53c05e1e7f1382c316afd6c763388b1"
SRC_URI[sha256sum] = "34db5e20bcf64e7071fe9ae25acaa7d72bdc4f11ab3ce59acc768ab62fe39276"
S = "${WORKDIR}/SDL2_ttf-${PV}"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
-do_configure_prepend() {
- touch ${S}/NEWS ${S}/README ${S}/AUTHORS ${S}/ChangeLog
+# links to libGL.so
+REQUIRED_DISTRO_FEATURES += "x11 opengl"
+do_configure_prepend() {
# Removing these files fixes a libtool version mismatch.
MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
@@ -25,3 +27,4 @@ do_configure_prepend() {
rm -f ${S}/acinclude/$i
done
}
+ASNEEDED = ""