aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval@huawei.com>2021-10-29 10:33:25 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-26 16:13:00 -0800
commit9f9bb90be05e568afbdf16bda6cf7b0eefac0373 (patch)
treeae9a40d9f5b20cac7f98f42bd4ef2935a500bbd2
parent9b3c3c080382d6b557705978c6719edc5ef4a2db (diff)
downloadmeta-openembedded-9f9bb90be05e568afbdf16bda6cf7b0eefac0373.tar.gz
pim435: Add recipe for C implementation for userspace driver app
Origin: https://booting.oniroproject.org/distro/oniro/-/merge_requests/402 Forwarded: https://github.com/openembedded/meta-openembedded/pull/493 Relate-to: https://git.ostc-eu.org/distro/components/vending-machine-control-application/-/issues/2 Relate-to: https://booting.oniroproject.org/distro/oniro/-/merge_requests/416 Thanks-to: Andrei Gherzan's avatarAndrei Gherzan <andrei.gherzan@huawei.com> Signed-off-by: Philippe Coval <philippe.coval@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/pim435/pim435_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/pim435/pim435_git.bb b/meta-oe/recipes-core/pim435/pim435_git.bb
new file mode 100644
index 0000000000..f73a0fd54e
--- /dev/null
+++ b/meta-oe/recipes-core/pim435/pim435_git.bb
@@ -0,0 +1,22 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+HOMEPAGE = "https://booting.oniroproject.org/distro/components/pim435"
+SUMMARY = "A userspace driver application for PIM435 written in C"
+DESCRIPTION = "A userspace driver application for PIM435 (Pimoroni LED matrix) \
+written in C"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSES/MIT.txt;md5=7dda4e90ded66ab88b86f76169f28663"
+
+SRC_URI = "git://booting.oniroproject.org/distro/components/pim435;protocol=https;branch=main"
+SRCREV = "ee07a83de4d0ecdf4b5de20a7e374d36a9a6f5d5"
+S = "${WORKDIR}/git"
+
+DEPENDS = "i2c-tools"
+
+EXTRA_OEMAKE += "DESTDIR=${D}"
+
+do_install() {
+ oe_runmake install
+}