aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-03-05 09:43:26 -0600
committerArmin Kuster <akuster808@gmail.com>2023-03-07 06:54:00 -0500
commitea18a49b79fa1db73eb929e4e350a15c3b66d79e (patch)
treed4f6023113405207c62e8128688cf0602d2a15ce
parentb5b732876da1885ecbab2aa45f80d7a3086c5262 (diff)
downloadmeta-openembedded-ea18a49b79fa1db73eb929e4e350a15c3b66d79e.tar.gz
nlohmann-json: Allow empty main package for SDK
The header-only package cannot be included in the SDK without marking the main package with ALLOW_EMPTY. Fixes rootfs problem: ``` The following packages have unmet dependencies: imx-gpu-sdk : Depends: nlohmann-json but it is not installable E: Unable to correct problems, you have held broken packages. ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit f9c9e7a448b9d9f7d54bbf09970223db467eedb2) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb
index 502262820a..6cf27755e8 100644
--- a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb
+++ b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb
@@ -18,7 +18,7 @@ inherit cmake
EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
# nlohmann-json is a header only C++ library, so the main package will be empty.
-
+ALLOW_EMPTY:${PN} = "1"
RDEPENDS:${PN}-dev = ""
BBCLASSEXTEND = "native nativesdk"