aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-11-29 19:00:09 -0800
committerArmin Kuster <akuster808@gmail.com>2022-12-20 10:35:02 -0500
commit6d89943abc78d7529ad756e8078aac695c0b38e4 (patch)
treecba2f7a5110d6aa2a807eb9367e9742b8d80adcf
parentdfab7834b6d2bcfe7f6fafcc2b69273a5b0ad5c5 (diff)
downloadmeta-openembedded-6d89943abc78d7529ad756e8078aac695c0b38e4.tar.gz
volume-key: Inherit python3targetconfig
It uses python3-config during build to grok the python specific includedirs, therefore its important to ensure that target specific python3-config is used, otherwise currently it defaults to native python3-config which ends up adding native python3 include paths which might work out ok but is exposed when target is 32bit + lfs enabled, the headers don't match between native and target python and compile fails e.g. | In file included from /mnt/b/yoe/master/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/volume-key/0.3.12-r0/recipe-sysroot-native/usr/include/python3.11/Python.h:38: | /mnt/b/yoe/master/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/volume-key/0.3.12-r0/recipe-sysroot-native/usr/include/python3.11/pyport.h:601:2: error: "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)." | #error "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)." | ^ Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 44384179db0db8bbf489dbe0524a5e5aa2853603) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb b/meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb
index faf8dd362d..aff555ad54 100644
--- a/meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb
+++ b/meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "6ca3748fc1dad22c450bbf6601d4e706cb11c5e662d11bb4aeb473a9cd
SRCNAME = "volume_key"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit autotools python3native gettext pkgconfig
+inherit autotools python3native python3targetconfig gettext pkgconfig
DEPENDS += " \
util-linux \