aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnastasios Kavoukis <anastasios.kavoukis@arm.com>2021-07-28 20:19:16 +0100
committerArmin Kuster <akuster808@gmail.com>2021-11-02 05:44:30 -0700
commitd10d52aef959111a3edfc01aea4be2a248f8bc79 (patch)
tree4e6dbecf982999212319ee091f034c1afb7b1dea
parent6be10fe608c09653416ae8c85377056ccaa9f1b9 (diff)
downloadmeta-openembedded-d10d52aef959111a3edfc01aea4be2a248f8bc79.tar.gz
pm-qa: fix paths for shell scripts
Cherry-pick the following patch from upstream/master branch, as this fixes the following error(s) seen while running the 'pm-qa' scripts on the targets: cpufreq_01.sh: line 28: ../include/functions.sh: No such file or directory ----------------------------------------------- A commit in the repo of pm-qa: "adf9df9 Fix path to library files and change shebang line" Changed the text that sed was using to replace relative to absolute paths. As a result sed was not effectively finding the text "source ../include" to replace it, as the sed should be now searching for ". ../include". Similarly for "../Switches" Signed-off-by: Anastasios Kavoukis <anastasios.kavoukis@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 06a93a04efe2c2cbae6de93d07962be4dfa35019) Signed-off-by: Bhupesh Sharma <bhupesh.sharma@linaro.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-test/pm-qa/pm-qa_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-test/pm-qa/pm-qa_git.bb b/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
index 7e9971ea4c..bb641437c9 100644
--- a/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
+++ b/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
@@ -42,6 +42,7 @@ do_install () {
do
# Remove hardcoded relative paths
sed -i -e 's#..\/utils\/##' ${script}
+ sed -i -e 's#. ..\/Switches#${bindir}#g' ${script}
script_basename=`basename ${script}`
install -m 0755 $script ${D}${libdir}/${BPN}/${script_basename}
@@ -54,7 +55,7 @@ do_install () {
# if the script includes any helper scripts from the $libdir
# directory then change the source path to the absolute path
# to reflect the install location of the helper scripts.
- sed -i -e "s#source ../include#source ${libdir}/${BPN}#g" ${script}
+ sed -i -e "s#. ../include#. ${libdir}/${BPN}#g" ${script}
# Remove hardcoded relative paths
sed -i -e 's#..\/utils\/##' ${script}