aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 14:49:10 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:05 +0200
commitfe76f1ab77c118e077d2c98f405b6b78ad35a124 (patch)
treec58f86229942a17f87a9c0ec3b2942315b191cad
parent1e29c4586eaf7af68ec8ea4276114cc6aec05a11 (diff)
downloadmeta-openembedded-fe76f1ab77c118e077d2c98f405b6b78ad35a124.tar.gz
atftp: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/atftp/atftp/atftpd.service (renamed from meta-systemd/meta-oe/recipes-extended/atftp/atftp/atftpd.service)0
-rw-r--r--meta-oe/recipes-extended/atftp/atftp_git.bb19
-rw-r--r--meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend19
3 files changed, 17 insertions, 21 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/atftp/atftp/atftpd.service b/meta-oe/recipes-extended/atftp/atftp/atftpd.service
index 480bc702e9..480bc702e9 100644
--- a/meta-systemd/meta-oe/recipes-extended/atftp/atftp/atftpd.service
+++ b/meta-oe/recipes-extended/atftp/atftp/atftpd.service
diff --git a/meta-oe/recipes-extended/atftp/atftp_git.bb b/meta-oe/recipes-extended/atftp/atftp_git.bb
index 774dd68841..67a2c1b4c5 100644
--- a/meta-oe/recipes-extended/atftp/atftp_git.bb
+++ b/meta-oe/recipes-extended/atftp/atftp_git.bb
@@ -4,6 +4,7 @@ HOMEPAGE = "http://packages.debian.org/atftp"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
PV = "0.7.1+git${SRCPV}"
+PR = "r3"
SRCREV = "be3291a18c069ae23a124ffdc56d64a5ff0bbec7"
@@ -11,10 +12,11 @@ SRC_URI = "git://atftp.git.sourceforge.net/gitroot/atftp/atftp;protocol=git \
file://atftpd-0.7_circumvent_tftp_size_restrictions.patch \
file://atftpd-0.7_unprotected_assignments_crash.patch \
file://atftpd.init \
+ file://atftpd.service \
"
S = "${WORKDIR}/git"
-inherit autotools update-rc.d useradd
+inherit autotools update-rc.d useradd systemd
INITSCRIPT_PACKAGES = "${PN}d"
INITSCRIPT_NAME_${PN}d = "atftpd"
@@ -31,10 +33,23 @@ do_install_append() {
install -d ${D}/srv/tftp
rm ${D}${sbindir}/in.tftpd
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/atftpd.service ${D}${systemd_unitdir}/system
}
PACKAGES =+ "atftpd"
FILES_${PN} = "${bindir}/*"
-FILES_${PN}d = "${sbindir}/* ${sysconfdir}/init.d/* /srv/tftp"
+FILES_${PN}d = "${sbindir}/* \
+ ${sysconfdir}/init.d/* \
+ /srv/tftp \
+ ${systemd_unitdir}/system/atftpd.service \
+"
+
+SYSTEMD_PACKAGES = "${PN}d"
+SYSTEMD_SERVICE_${PN}d = "atftpd.service"
+RPROVIDES_${PN}d += "${PN}d-systemd"
+RREPLACES_${PN}d += "${PN}d-systemd"
+RCONFLICTS_${PN}d += "${PN}d-systemd"
diff --git a/meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend b/meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend
deleted file mode 100644
index ed9cf9dd79..0000000000
--- a/meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend
+++ /dev/null
@@ -1,19 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-PRINC := "${@int(PRINC) + 2}"
-
-inherit systemd
-
-SRC_URI += "file://atftpd.service"
-
-SYSTEMD_PACKAGES = "${PN}d"
-SYSTEMD_SERVICE_${PN}d = "atftpd.service"
-FILES_${PN}d += "${systemd_unitdir}/system/atftpd.service"
-RPROVIDES_${PN}d += "${PN}d-systemd"
-RREPLACES_${PN}d += "${PN}d-systemd"
-RCONFLICTS_${PN}d += "${PN}d-systemd"
-do_install_append() {
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/atftpd.service ${D}${systemd_unitdir}/system
-}
-