aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-19 18:39:21 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-20 11:05:12 -0700
commit87cdaf04b1e111d9f0809f4f5248f474407e4f25 (patch)
tree7a4ed3836d71c2c25c8a5bcc890d4ec7f0035f71
parenteb30a6b92ba45eae63cd8aefa37dc3961ad5b7bb (diff)
downloadmeta-openembedded-master.tar.gz
ydotool: Do not package systemd unit files on non-systemd distrosHEADmaster
Fixes ERROR: ydotool-1.0.4+git-r0 do_package: QA Issue: ydotool: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/systemd /usr/lib/systemd/user /usr/lib/systemd/user/ydotoold.service Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/ydotool/ydotool_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/ydotool/ydotool_git.bb b/meta-oe/recipes-graphics/ydotool/ydotool_git.bb
index c1427457d1..3acf70235e 100644
--- a/meta-oe/recipes-graphics/ydotool/ydotool_git.bb
+++ b/meta-oe/recipes-graphics/ydotool/ydotool_git.bb
@@ -16,5 +16,11 @@ EXTRA_OECMAKE = "\
-DBUILD_DOCS=OFF \
"
+do_install:append() {
+ if ! ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ rm -rf ${D}${systemd_user_unitdir}
+ rmdir ${D}${nonarch_libdir}/systemd ${D}${nonarch_libdir}
+ fi
+}
SYSTEMD_SERVICE:${PN} = "ydotoold.service"
SYSTEMD_AUTO_ENABLE = "disable"